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WHAT IS “BREKEL FACE”  

 

 

 

“Brekel Face” is a Windows application that enables 3D animators to record and stream 3D face tracking data 

using a Microsoft Kinect sensor. 

Internally tracking is done using the Microsoft Kinect SDK. 

 

It is written by Jasper Brekelmans, so in case you’re wondering that’s what “Brekel” refers to. 

“Brekel” is pronounced as “Break–uhl”. 

 

  



REQUIREMENTS 

 - Kinect for Windows or Kinect for XBox sensor 

- Power supply for the Kinect sensor 

 - Microsoft Windows 7 or higher 

 - Core i5 or i7 CPU 

 - Dedicated USB 2.0 (or 3.0) bus 

 - 4 GB RAM or more 

 - Graphics card with OpenGL support 

 

A Kinect for Windows sensor will also support ‘near mode’ allowing capture as close to 40 cm from the sensor 

resulting in more accurate data. 

The minimum distance for a Kinect for Xbox sensor is 80 cm resulting in fewer pixels for the face and slightly 

less accurate tracking. 

 

The Kinect for Windows sensor also supports control of the color camera settings like auto exposure, 

whitebalance etc. 

 

Note: when you bought your Kinect for Xbox separately you should have a separate power supply. 

If you’ve bought it bundled with an Xbox360 game console you need to buy a separate power supply, USB only 

will not be enough. 

  



 

INSTALLATION 

 

In order for “Brekel Kinect Pro Face” to work you will need to have the Microsoft drivers installed for your 

Kinect sensor. If you’ve got a different set of Kinect drivers installed (OpenNI, OpenKinect or CLNui for 

example) please first uninstall them. 

(Note that the free “Brekel Kinect” application uses the OpenNI drivers) 

 

The installer should have taken care of installing the drivers already but in case you want more details: 

 

Please consult the following page for driver download and installation help: 

http://www.microsoft.com/en-us/kinectforwindows/develop/developer-downloads.aspx 

 

Kinect for Xbox sensors will ONLY work with the full SDK 

 

 

Kinect for Windows sensors will work with the full SDK as well as the runtime (which is smaller to download) 

 

 

The “Brekel Kinect Pro Face” installer will try to automatically detect any installed MotionBuilder versions (in 

the default locations) and install the appropriate plugins for streaming. 

You can also manually copy the MotionBuilder plugins from the installed folder.  

http://www.microsoft.com/en-us/kinectforwindows/develop/developer-downloads.aspx


LICENSING 

 

With your purchase you should have received a download link for the retail version of the software and an 

email with your license code. (Please allow up to 24 hours for processing your request and double check your 

spam filter) 

 

The retail version will work immediately and with no restrictions even without a valid license, but will need 

activation within 5 days for continuous operation. 

 

You can activate your copy by using the “File > Install License” option from the menu. 

 

 

It will ask you to browse for your license file (which was attached to the mail). 

The license will automatically be copied to your “C:\ProgramData” folder and be active upon restart of the 

application. 

 

To display the current license info use the “File > Show License Info” option from the menu to display a 

window like the following: 

 

  



THE MAIN INTERFACE 

 

 

The interface is divided in 6 main groups. 

- 3D View 

- Tracking Results 

- Record 

- Video 

- Depth 

- System Info 

These groups can be undocked and turned into a floating window by dragging them from their title bar. 

Double clicking on the taskbar of a floating window will dock it back into the main window. 

The state will automatically be saved on exit and reloaded on start. 

  



THE 3D VIEW 

 

 

 

The main area displays the tracking data in the form of a 3D mesh 

For navigation: 

- Left mouse button for orbit 

- Middle mouse button for dolly 

- Right mouse button for drag 

- Mouse wheel for dolly 

 

Below the 3D view the audio (coming from the built in microphones) is displayed as a waveform. 

  



FPS 

The speed (in frames per second) the tracker is running at, note that this can be higher than the video/depth 

input streams since filtering/smoothing can be applied to the data on inbetween frames. 

 

Grid 

Toggles showing the grid in the 3D view. 

 

Head Origin 

Toggles drawing the axis of the head origin in the 3D view. 

 

Mesh 

Toggles drawing of the 3D head mesh and points. 

 

PointSize 

Defines the size of the points of the mesh. 

0.0 turns point drawing in the 3D view OFF. 

 

Center View (F12) 

Centers the head in the 3D viewport, hitting F12 will do the same. 

  



Filtering Head 

Applies filtering to the position & rotation of the head. 

0.0 disables filtering 

1.0 filters so much the head will be static 

 

Filtering Face 

Applies filtering to the face points 

0.0 disables filtering 

1.0 filters so much the points will be static 

 

Tilt Angle 

The angle of the Kinect, the Kinect’s motor will be activated upon release of the handle. 

 

  



TRACKING RESULTS 

 

 

This shows the tracking data in numeric form. 

 

Tracking / Tracking (skeleton assisted) / No Face Found 

Displays one of these states depending on if the tracker was able to find a face or not. 

Skeleton assisted tracking occurs when the user is recognized (note that there will also be a colored indication 

in the depth view) Tracking robustness will be improved, especially when using a Kinect for Windows sensor in 

near mode. 

 

Position 

The position of the head. 

 

Rotation 

The rotation of the head as an euler angle in degrees. 



Animation Units 

A list of the “Animation Units”, these can be used to drive animated blend/morph shapes for example. 

 

Static Shape Units 

A list of “Shape Units”, these describe the basic structure and shape of the face, eyes width, mouth width, 

overall height etc. Depending on your needs they may be less relevant. 

  



 

RECORD 

3D Tab 

 

Marker Set 

When saving FBX and/or BVH files this will pick which markers to include. 

All Points will include all the points visible in the 3D view, note that not all points will contain unique face 

motion. The naming convention will use numbers. 

  



Face Points will only include the points that contain unique face motion and will also use human readable 

names. Here is a list of names and numbers that are included with this markerset: 

Brow Outer  R   48 
Brow Middle R   51 
Brow Inner  R   50 
Brow Inner  L   17 
Brow Middle L   18 
Brow Outer  L   15 
 
Mouth Corner R   64 
Mouth Upper  R   80 
Mouth Upper  C   7  
Mouth Upper  L   79 
Mouth Corner L   31 
Mouth Lower  L   85 
Mouth Lower  C   8 
Mouth Lower  R   86 
 
Mouth Inner Corner R  89 
Mouth Inner Upper  R  82 
Mouth Inner Upper  C  87 
Mouth Inner Upper  L  81 
Mouth Inner Corner L  88 
Mouth Inner Lower  L  83 
Mouth Inner Lower  C  40 
Mouth Inner Lower  R  84 
 
Cheek R    91 
Cheek L    90 
 
Chin    10 

FBX 

Toggles if the 3D tracking data should be exported to disk in the FBX format. 

(Note: the data is kept in memory and saved to disk when the recording is stopped) 

 

FBX file format 

FBX files should be readable by most 3D packages and it includes data for the head translation /rotation, 

animation units (stored as custom attributes on the head object) and facial features. 

V7.3 is the latest version, v6.1 should be compatible with older 3D packages. 

 

Object Type 

You can either export Joints or Markers in FBX files. 

The contained data is exactly the same, the only difference is the type of object used. 

Joints may be useful if you want to directly skin to the points. 

Markers may be useful for general purpose use. 

 

 



BVH 

Toggles if the 3D tracking data should be exported to disk as a BVH file. 

BVH files can only contain joint/bone data and therefore can only include the head translation/rotation and 

facial feature positions. Animation Unit data can not be exported in BVH format. 

 

BVH type 

Specifies what data to save to the BVH file, some programs like one or the other so please experiment a bit 

with what suits your workflow best. 

• Rotation, exports facial feature data as rotating bones and head translations & rotations. 

• Rotation with Neck, exports facial features as rotating bones, head rotations on the head 

bone and head translations as rotations on a neck bone 

• Translation, exports all data as translations on bones 

• Animation Units, exports animation data as bones 

 

Poser/DAZ (using .PZ2 files) 

Toggles if the 3D tracking data should be exported to disk in the PZ2 format for use in Poser/DAZ. 

 

Poser/DAZ Mapping Template 

In order to support the various Poser/DAZ figures you need to choose (or create) a template that matches the 

structure of your figure. 

This relates the ‘Animation Units’ of Brekel Kinect Pro Face to the available face morphs on the figure. Please 

refer to the chapter in this manual dedicated to this topic for further information. 

 

TXT 

Toggles if the 3D tracking data should be exported to disk as a text file. 

This file includes all the internal data in a human readable format and should be ideal in case you want to write 

your own importer. 

Note that there is a MEL script for Maya that demonstrates importing this data into your Maya scene, it is 

located in the “Maya MEL script” subfolder of the Brekel Kinect Pro Face installed folder. 

 

CSV 

Writes to a Comma Separated Values file. 

This could for example be used to analyze the data in a spreadsheet. 



Audio Tab 

 

 

Available Devices 

List the available audio devices that can be used for recording and allows you to select one of them. 

 

Number of Channels 

Switches between Mono and Stereo recording. 

 

Sampling Rate 

Sample rate to record (in Hz). 

 

Sample Size 

Amount of bits (8 or 16) used for recording. 

 

Note that audio is always recorder in the WAV format. 

  



Video Tab 

 

AVI 

Toggles if the video data should be exported to disk in the AVI movie format. 

 

Ask for codec 

When turned ON the program will ask which codec to use for the AVI file. (Available codecs will depend on 

what is installed on your system) 

When turned OFF the XVID codec will automatically be used. Since it has a nice tradeoff of quality, filesize and 

speed. 

If you’re having trouble with codecs I can recommend the K-Lite codec pack and/or Xvid: 

http://www.codecguide.com/download_kl.htm 

http://www.xvid.org/ 

Remember to also install the x64 version of the codec if you’re using the x64 version of Brekel Kinect Pro Face. 

 

http://www.codecguide.com/download_kl.htm
http://www.xvid.org/


 

 

 

Direct to Disk 

When turned ON, video frames will be compressed and saved to disk during the recording. Depending on your 

CPU speed, selected codec and disk speed this uses the least amount of memory but has a chance of dropping 

frames on slow machines. 

When turned OFF, video frames will be recorded in memory first and compressed to disk after the recording is 

stopped. If your system has enough memory this is the fastest method and has the lowest risk of frames being 

dropped. 

 

Overlay Filename 

Prints the filename into the video 

 

Overlay Frame Number 

Prints the frame number into the video 

  



Network Tab 

 

Protocol 

Selects either TCP/IP or UDP as the streaming protocol, or turns streaming off. 

 

Port 

The network port from which data will be streamed out of. (default 8874) 

 

State 

The current state of the network streaming. 

 

Please make sure security software (firewall) is not blocking network streaming! 

  



Bottom part of Record window 

 

Output Folder 

The folder where the recorded output files will be placed. 

 

Output Filename 

The filename of the recorded files. (disabled when Auto Filename is turned on) 

 

Auto Filename 

When turned on a filename will automatically be created using the current date/time. 

 

Open Folder 

Opens the output folder in Windows Explorer. 

 

Browse 

Opens a file browser so you can specify the output folder. 

 

Start Delay 

When bigger than 0 a countdown will start after starting a recording, giving you a few seconds to get into 

position before capture will start. 

During countdown there will be beeps played over the speakers every second, and the amount of remaining 

seconds will also be shown visually in the 3D window. 

 

Recorded 

Displays the amount of frames and seconds recorded in the last take. 

 

Start/Stop Recording 

Toggle button for starting & stopping the recording. (Note the button turns red while recording) 

 

 



VIDEO 

 

Shows the incoming video stream from the Kinect sensor. 

 

FPS 

The speed (in frames per second) of the incoming video stream, this should be roughly the same as depicted in 

the chosen “Video Resolution”. If it is drastically lower your system may be too slow. 

 

Draw 

Turns drawing in the GUI ON/OFF, this may save a few CPU cycles on slow machines. 

 

Video Resolution 

The Kinect can work at 640x480 at 30fps, or at 1280x960 12fps. 

Note that the application needs to restart for the new resolution to take effect. 

  



PointSize 

The size of the 2D tracking points as displayed as an overlay on the video. 

1.0 turns point drawing in the video window OFF. 

 

Camera Settings (only available on Kinect for Windows devices) 

Opens a new window that allows control over Exposure and Color settings, useful when working in low light 

situations or when you want manual control instead of automatically adjusting settings. 

 

 

Note that since face tracking uses the video stream it is important to tune this (both physically with your light 

setup and using the Camera Settings if available) to give a well lit view of the face. 

  



 

DEPTH 

 

Shows the incoming depth stream from the Kinect sensor. 

 

FPS 

The speed (in frames per second) of the incoming depth stream, this should be roughly the same as depicted in 

the chosen “Depth Resolution”. If it is drastically lower your system may be too slow. 

 

Draw 

Turns drawing in the GUI ON/OFF, this may save a few CPU cycles on slow machines. 

 

Depth Resolution 

The Kinect can work at 640x480 or at 320x240, both are at 30fps. 

Note that the application needs to restart for the new resolution to take effect. 

 



Near Mode (not available on Kinect for Xbox sensors) 

When turned ON the Kinect will senses depths roughly between 40cm and 3 meters from the sensor. 

When turned OFF the Kinect will senses depths roughly between 80cm and 4 meters from the sensor. 

 

Note that when a person is detected the Depth view will reflect this by drawing the pixels belonging to that 

user in a different color. User detection will usually need a few frames of movement. 

 

This will also automatically enable skeleton assisted tracking mode which will improve stability especially when 

being very close to the sensor when using near mode on a Kinect for Windows sensor. 

  



TOP MENU 

File > Install License 

Let’s you browse to a license file and installs it to be used for the next time the application is run. 

 

File > Show License Info 

Shows if a license is installed and who it belongs to. 

 

File > Exit 

Saves settings and exits the application (same as clicking the X in the top right corner) 

  



Settings > Check for new version on start 

Will check online if a new version is available and lets the user know if there is one. 

 

Settings > Use Multi Threading 

When turned ON does more processing in parallel for multi-core/multi-cpu machines. 

Note that depending on your machine’s configuration, and especially the amount of available cores and their 

speed, this may be faster or slower. 

 

Settings > Tweak Sleep Time (advanced users) 

Internally processing is done on multiple threads, when no new data is available these threads go to sleep for a 

few milliseconds until they request new data. 

Advanced users may want to tweak this setting to gain a few FPS on slower machines, or gain responsiveness 

on faster machines that still have CPU time to spare. 

Note that bumping this too high will force evaluation to run at speeds lower than 30 FPS and therefore drop 

frames. 

 

Settings > Auto Scale Animation Units 

When turned ON Animation Units will automatically be scaled to fit in the -1 to +1 range based on the 

observed extremities of expressions that have been captures so far. 

When turned OFF Animation Units are not altered and are the raw values returned by the Microsoft Kinect 

SDK. 

  



Window > Dark Skin 

Toggles between the regular style (light) GUI and the dark style. 

 

Window > Record 

Toggles visibility of the “Record” dock. 

 

Window > Tracking Results 

Toggles visibility of the “Tracking Results” dock. 

 

Window > Video 

Toggles visibility of the “Video” dock. 

 

Window > Depth 

Toggles visibility of the “Depth” dock. 

 

Window > System Info 

Toggles visibility of the “System Info” dock. 

 

  



Help > Open Help File (PDF) 

Opens this help file, which can also be found in the installation folder. 

 

Help > Open Downloads Page 

Opens the standard web browser and directs it to the webpage with the latest installer downloads. 

 

Help > Open Forums 

Opens the standard web browser and directs it to the user forums. 

  



POSER/DAZ WORKFLOW 

 

Brekel Kinect Pro Face can be used to drive Poser/DAZ figures by the use of .PZ2 files. 

Poser/DAZ figures usually have a list of sliders for a range of different facial expressions, Brekel Kinect Pro Face 

comes with several mapping templates to relate these to the capture data. 

When capturing it is important you select a mapping template that matches the character you will be applying 

it to in Poser/DAZ. 

 

Templates are stored in the “Poser Mapping Files” subfolder of the Brekel Kinect Pro Face installation, usually 

located somewhere here: 

C:\Program Files\Brekel Kinect Pro Face x64\Poser Mapping Files 

(If you’re edited templates don’t save correctly try running the program as Administrato) 

 

Templates can easily be shared since they are regular text files and the list of available templates is 

automatically updated when the Brekel Kinect Pro Face program starts. 

 

 

You can adjust the mapping templates or even create new ones by selecting the “~ Edit Templates~” option 

from the list of template selections, this will bring up the template editor. 



POSER TEMPLATE EDITOR 

 

At the top you can select the template you want to edit, save any adjustments you did or create a new 

template. 

 

In the second section you can specify how the captured head rotation is applied to your Poser/DAZ figure. 

You can distribute the rotation onto the neck and/or head bone by adjusting the multipliers. 

When all values are 0 no head rotations will be used which can be useful in case you want to keep existing 

head animation or poses. 

It is usually a good idea to distribute the rotation onto both the neck and head bone and make sure they both 

add up to 1.0 



The bottom section defines how ‘Animation Units; from the face tracker are mapped to the available sliders on 

the Poser/DAZ figure. 

In the first column, “Brekel Shape Name” you select one of the available ‘Animation Units’ from the tracker. 

 

The following ones have a range from 0.0 to 1.0 

Brows Inner Up 

Brows Inner Down 

Brows Outer Up 

Brows Outer Down 

Lip Stretch 

Lip Kiss 

Lip Corners Up 

Lip Corners Down 

Upper Lip Up 

Upper Lip Down 

Jaw Open 

 

And these have a range from -1.0 to +1.0 

Upper Lip Raiser 

Jaw Lowerer 

Lip Stretcher 

Brow Lowerer 

Lip Corner Depressor 

Outer Brow Raiser 

  



In the next column you need to specify the name of the slider in Poser/DAZ to drive. 

These can be a bit tricky to figure out since what Poser/DAZ displays in the GUI isn’t always what it uses 

internally. 

 

A good way to figure these out is to look through an existing .PZ2 or .CR2 file and search for things like “Brow”, 

“Mouth” or “Lips”. 

You can also take a look at the existing templates and see how they are structured and start from there. 

 

In the third column you can specify a multiplier, you can use higher numbers to exaggerate motion for a 

channel or even negative ones to flip the motion. This will also depend on how extreme the shape was 

modeled on the Poser/DAZ figure. 

 

The fourth column allows you to specify an offset. (which internally is applied after the value is scaled by the 

multiplier) 

You can use this if you want a channels not to default to 0, for example you can give brows a negative offset to 

make your character’s neutral expression to be angry. 

 

The “Remove” button at the right of each “Shape Pair” allows you to remove a pair. 

(Note that any pairs whose “Poser/DAZ Shape Name” is empty will be cleaned up when saving the template) 

 

The “Add Shape Pair” at the bottom will add a new pair.  



THE ACTUAL TRACKING DATA 

 

The face tracker exposes the following tracking data: 

- head position vector 

- head rotation euler angle  

- animation units (not supported in BVH format) 

- shape units (not supported in BVH format) 

- 3D points 

- 2D points (only supported in TXT format) 

 

Tracking is done using both the color and depth images, these are some guidelines for good tracking: 

- Make sure the video stream shows a nice clear and well lit 

- Be as close to the sensor as possible, but being too close will not track well 

o A good distance is 1.5x arm length from the Kinect 

- Tracking works within the following ranges: 

o Pitch of less than 20 degrees, best less than 10 degrees 

o Roll of less than 90 degrees, best less than 45 degrees 

o Yaw of less than 45 degrees, best less than 30 degrees 

 

 

  



ANIMATION UNITS 

 

These describe the current expression of the tracked face as a set of values and can be used to drive blend 

shapes / morph targets on a 3D character. 

 

They are updated every frame and range from 0 to 1. 

Where 0 represents no deviation from the neutral face. 

And 1 the maximum amount of displacement. 

 

 

Currently the following animation units are supported: 

Brows Inner Up 

Brows Inner Down 

Brows Outer Up 

Brows Outer Down 

Lip Stretch 

Lip Kiss 

Lip Corners Up 

Lip Corners Down 

Upper Lip Up 

Upper Lip Down 

Jaw Open 

 

 

 

 

Note that the BVH export format does not support Animation Units, only the FBX and TXT formats do. 

(the network protocol will also stream these out)  



SHAPE UNITS 

 

These describe the structure of the face and could be used to personalize an avatar. 

They are static and don’t change per frame. 

 

Currently the following shape units are supported: 

Head Height 

Eyebrows Vertical Position 

Eyes Vertical Position 

Eyes Width 

Eyes Height 

Eye Separation Distance 

Nose Vertical Position 

Mouth Vertical Position 

Mouth Width 

Eyes Vertical Difference 

Chin Width 

 

 

 

 

 

 

Note that only the TXT export format supports Shape Units 

(the network protocol will also stream these out) 

  



3D POINTS 

 

3D points are expressed in a Y-up coordinate system where the Kinect is at the center of the world. 

The full set of points represents the face mesh as displayed in the 3D view. 

The subset of “Face Points” is drawn in the 3D view with bigger points, they contain the useful expression 

information. 

 

The following points are part of the “Face Points” subset, the number represents where they are in the full set 

of points 

Brow Outer  R   48 
Brow Middle R   51 
Brow Inner  R   50 
Brow Inner  L   17 
Brow Middle L   18 
Brow Outer  L   15 
 
Mouth Corner R   64 
Mouth Upper  R   80 
Mouth Upper  C   7 
Mouth Upper  L   79 
Mouth Corner L   31 
Mouth Lower  L   85 
Mouth Lower  C   8 
Mouth Lower  R   86 
 
Mouth Inner Corner R  89 
Mouth Inner Upper  R  82 
Mouth Inner Upper  C  87 
Mouth Inner Upper  L  81 
Mouth Inner Corner L  88 
Mouth Inner Lower  L  83 
Mouth Inner Lower  C  40 
Mouth Inner Lower  R  84 
 
Cheek R    91 
Cheek L    90 
 
Chin    10 

 

3D points are exported in the FBX, BVH and TXT formats, as well as streamed out in the network protocol. 

 

Both the TXT and network protocol give access to the points in global space (relative to the Kinect), or local 

space (relative to the head) 

 

 

  



2D POINTS 

 

2D points are expressed in the coordinate system of the video window and their main purpose is for 

visualization. 

 

2D points are only exported in the TXT format and streamed out in the network protocol. 

  



MOTIONBUILDER PLUGIN INSTALLATION 

The installer should have automatically installed the plugins for the available versions of MotionBuilder as long 

as MotionBuilder was installed in the default location under “Program Files”. 

And you should now have a “Brekel Kinect Pro Face” Device listed under the “Devices” folder of the “Asset 

Browser”. 

 

 

If it doesn’t show up, you can find all the plugins for the various MotionBuilder versions (2009-2014 both 32- 

and 64 bit) in the “Brekel Kinect Pro Face” installation folder, usually in: 

C:\Program Files\Brekel Kinect Pro Face\MotionBuilder plugins 

 

Simply copy the .dll file of your particular MotionBuilder version to it’s plugin folder. 

Typically for a 32 bit version: 

C:\Program Files (x86)\Autodesk\MotionBuilder 2013\bin\win32\plugins 

 

For a 64 bit version: 

 C:\Program Files\Autodesk\MotionBuilder 2013\bin\x64\plugins 

  



USING THE MOTIONBUILDER PLUGIN 

First make sure “Brekel Kinect Pro Face” is running and tracking a face. 

To setup a MotionBuilder scene go through the following steps: 

- drag a “Brekel Kinect Pro Face Device” from the “Devices” folder in the “Asset Browser” into your 

scene. 

- In the GUI for the device make sure the “Hostname/IP” points to the machine running the          

“Brekel Kinect Pro Face” application. This can either be a separate machine that is reachable over a 

network connection or the same machine. 

- (Note: if both applications are running on the same machine you can simply use the default 

Hostname/IP of “127.0.0.1”) 

- Toggle the “Online” button to turn the device on, data will now be streaming as can be seen in the 

properties of the device (1) 

- Under “Model binding:” (2) hit the “None” option and then “Create”, this will create a model 

hierarchy in your scene containing the head transformations and marker positions 

 

 

To record a sequence: 

- Make sure “Online” on the device is toggled ON 

- Make sure “Live” on the device is toggled ON 

- Make sure “Recording” on the device is toggled ON 

- Make sure the “Record” button on the timeline transport controls is toggled ON 

- Hit the Play button, and Stop button once the action is over 

 

To play back a recording: 

- Make sure “Online” on the device is toggled ON 

- Make sure “Live” on the device is toggled OFF 

- Hit Play on the timeline transport controls or scrub trough the timeline 

  



Hostname/IP 

Should point to the machine running Brekel Kinect Pro Face. 

If both MotionBuilder and Pro Body run on the same machine you can also leave this at the default of localhost 

or 127.0.0.1 

 

Port 

Should be the same port as used in the Brekel Kinect Pro Face application. (default 8874) 

 

Protocol 

Should be the same protocol (TCP/IP or UDP) as used in the Brekel Kinect Pro Face application. 

 

Animation Unit Scale 

By default the animation units will be scaled from 0-100 so they comply with MotionBuilder’s attribute range 

for blendShapes. 

The “Animation Unit Scale” allows you to change this range for example if you want them to be from 0-1 

change this value to 1.0 

 

 

Character Faces 

This lists all the characterFace nodes in the scene and allows you to quickly create a new one. 

The device will automatically drive the channels of the selected characterFace node with the data of the 

Animation Units, as long as the names match. The “Create New” button creates a compliant characterFace 

node that is ready for use. 

You can then very easily hook your blendshapes and/or bone poses into to these channels and get your rig 

moving. 

  



LIVE STREAMING INTO UNITY 

 

If you want to stream data into the Unity3D engine (both the Pro and Free version of Unity are supported) you 

can use the C# script that is included named “BrekelKinectProFace_Streamer.cs” 

You can find this in the subfolder labeled “Unity3D” in your “Brekel Kinect Pro Face” installation folder. 

 

 

Once you’ve copied the “BrekelKinectProFace_Streamer.cs” script to your Unity project, simply drag it onto 

any gameobject in the scene and make sure the “Host” attribute points to the machine running “Brekel Kinect 

Pro Face”. (or leave it to “localhost” if that is the same machine as Unity is running on”) 

 

This script serves as a starting point but it shows how to connect to the TCP server, stream all available data 

and make them accessible through the scripts’s attributes. 

As well as how to apply some of the data to “Debug Objects”. 

  



LIVE STREAMING INTO UNREAL ENGINE 4  

 

Live data can be streamed into the Unreal Engine 4 engine using its Live Link feature. 

 

In the Brekel app make sure "Unreal Engine 4 Live Link" is enabled on the "Network" panel 

 

 

First make sure you enable this feature in the UE4 engine: 

• Click Edit > Plugins 

• Enable "Live Link" under "Animation" 

 

 

 

 



 

Click Window > Live Link 

 

 

In Live Link Window 

• click Add > Message Bus Source 

• "Brekel Face v1" should be listed under Source Type/Machine, click it and hit Ok 

 

 

• A “Face” subject should now be listed under "Subject Name" 

 



In the Content Browser: 

• Import "base_face.fbx" 

• You can find this file in the “UnrealEngine4” folder inside the Brekel installation folder, usually 

something like here: 

• C:\Program Files\Brekel Kinect Pro Face x64\UnrealEngine4 

 

Make sure that “Import Morph Targets” is enabled in the “FBX Import Options” under the advanced “Mesh” 

options: 

 

 

  



• Add New - Animation BluePrint 

 

 

• Pick “base_face_Skeleton” from the list 

 

 

  



• Open the newly created blueprint by double clicking on it 

• Right click in empty blueprint area 

• Create a new "Live Link Pose" node 

 

  



• Change Subject Name to “Face” 

 

 

• Connect Live Link Pose node to Final Animation Pose node 

 

 

• Hit save and compile 

o You should now see a live data connection between the nodes 

o You should now see live data in the 3D window 

 



STREAMING PROTOCOL 

 

“Brekel Kinect Pro Face” has a TCP server running on port 8874. 
 
Once a connection is established the following struct is passed per frame: 
 
struct   
{ 
 int isTracked; 
 
 float head_translation[3]; 
 float head_rotation[3]; 
 
 int num_shape_units; 
 int num_animation_units; 
 int num_points2D; 
 int num_points3D; 
 
 float shape_units[NUM_SHAPE_UNITS]; 
 float animation_units[NUM_ANIM_UNITS]; 
 float points2D[NUM_POINTS_2D*2];  // x,y 
 float points3D_global[NUM_POINTS_3D*3]; // x,y,z 
 float points3D_local[NUM_POINTS_3D*3];  // x,y,z 
}; 

 

In the 1.x version (which uses Microsoft Kinect SDK 1.6) 

num_shape_units should always be 11 

num_animation_units should always be 11 

num_points2D should be 100 

num_points3D should be 121 

 

The order and names of the shape and animation units can be seen in the the tables with the same names in 

the GUI application. 

The 2D points can be seen overlayed on the video image. 

The head translation/rotation is visualized in the 3D window as the colored axis known as the Head Origin. 

The 3D_local points are visualized as the points and mesh in the 3D window, they are local to the Head Origin. 

The 3D_global points are not visualized but they are the same as the local points except in global space. 

 

Every data packet starts with 3 bytes describing the start of a packet and buffersize, you can ignore these an 

can start parsing all of the above information starting at the 4th byte in the packet you receive. 

  



RUNNING IN COMMANDLINE MODE 

 

For advanced users who are only interested in using the network streaming it is possible to run Brekel Kinect 

Pro Face in command line mode so it uses as few CPU power as possible. 

 

Simply add the “-commandline” argument when starting the application and it will run without the GUI and 

still stream out the data over the TCP/UDP network socket. 

 

Note that settings will be loaded from the registry as usual, so you can use the GUI to set things like tilt angle, 

near mode, smoothing settings etc. 

 

 

  



COMMANDLINE OPTIONS 

 

Advanced users can use one or more of the following commandline options: 

 

-sensorId 0 

In case you have multiple sensors connected to one machine you can specify which 

one to use by changing the value of 0 to a higher number. (note that this 

currently cannot be set from the GUI) 

 

-noVBO 

Adding this will force the rendering to not use any Vertex Buffer Object 

optimizations, which may cause problems on certain graphics cards and/or drivers. 

(note that this currently cannot be set from the GUI) 

 

-commandline 

Runs without a GUI, enabling only the network streaming, but still loads the 

settings that were used by the GUI version. 

See next chapter for more info. 

 

-elevationAngle 0 

Sets the device’s tilt angle to the chosen value, valid range is from -27 to +27 

 

-videoResolution 0 

0 sets video resolution to 640 x 480 (30 fps) 

1 sets video resolution to 1280 x 960 (12fps) 

 

-depthResolution 0 

0 sets depth resolution to 320 x 240 (30 fps) 

1 sets video resolution to 640 x 480 (30 fps) 

 

 



 

-nearMode 0 

0 turns nearMode OFF 

1 turns nearMode ON (Kinect for Windows devices only) 

 

-sleeptime 5 

Sets how many milliseconds the internal threads will wait before they check for 

fresh data. 

 

-multiThreading 

Forces multi threading to be used wherever possible. 

 

-networkProtocol 0 

0 turns network streaming OFF 

1 sets network streaming protocol to TCP 

2 sets network streaming protocol to UDP 

 

-networkPort 8874 

Sets the network streaming to the chosen port. 

 

-filterHead 0.85 

Sets amount of filtering for the head position/rotation, valid range is from 0.0 - 

1.0 

 

-filterFace 0.0 

Sets amount of filtering for the face points, valid range is from 0.0 - 1.0 

  



-OSC_enable 0 

 0 disable OSC data streaming 

 1 enable OSC data streaming 

 

-OSC_host localhost 

 Sets the hostname/IP of the machine to which to stream OSC data 

 

-OSC_port 7775 

 Sets the port over which to stream OSC data 

 

 


